Honda XRV Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter #1
Got a problem with the twin! Put a new battery on but it keeps draining it flat. Any assistance much appreciated.

Sent from my HTC One using Tapatalk
 

·
Registered
Joined
·
1,412 Posts
1/ is it charging?

http://www.electrosport.com/technical-resources/library/diagnosis/pdf/fault-finding-diagram.pdf


2/ connector block burnt/corroded?

the three yellow wires coming from the engine stator/mag join a connector block to the reg/rec. rear left on the rd07s', rear right rd04. Over time the block warms/melts causing bad contacts. flat battery / knackered battery / bust reg/rec / problems can result. check the block, hard solder the wires together (DOESN'T MATTER WHICH TO WHICH) adhesive heat shrink to finish.

i'm sure options 3-100 shall be along... cheapest/simplest first. good luck
 

·
Registered
Joined
·
35 Posts
Discussion Starter #5
Checked the block and three yellow wires and all the other wires around this area but nothing looking melted or out of order.

Any other ideas?
 

·
Registered
Joined
·
552 Posts
Do you have multimeter?
If you do check voltage on your battery with bike running at 3000-4000rpm, with lights off and on. Ideally it should be over 14volts. If much lower (<13volts) then your regulator is dead
 

·
Registered
Joined
·
552 Posts
Motorcycle battery because of small capacity will drain rather quickly if not charged. Also something could be draining it when the bike is off (alarm for example). You can measure drain current also. Take off cable from negative battery terminal and measure current between negative battery terminal and removed cable when the bike is off. It shouldn't read more than couple of miliamps.
 
1 - 9 of 9 Posts
Top