Honda XRV Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter #1
I'm continuing to quietly fettle, clean and tidy the '01 TA 650 I bought recently. After being pleasantly surprised at how easy the tank came off I opened up the airbox. Filter was genuine Honda and in good condition. However, I was disturbed to find a fair bit of dust on the clean side of the filter.

The rubber sealing gasket is in place but I considered whether it needs to be replaced. I then fitted the filter and airbox lid back on to check the fit and found at least three places where the airbox seems to be distorted, creating gaps between the lid and body of the 'box (see photos).

I am assuming this is the likely source of the problem. Is this a common fault with the TA? If so, are there any recommended fixes? If not common, does anyone have any suggestions as to possible cause and a possible fix?

Many thanks for any assistance. 100_2324.JPG 100_2325.JPG 100_2326.JPG
 

·
Registered
Joined
·
7,695 Posts
Not seen one like that before.
It looks like someone has tried to force it with the screws still in place!

Sent from my SM-A320FL using Tapatalk
 

·
Registered
Joined
·
23 Posts
Discussion Starter #3
Thought I would update on this.

I noticed a bike dismantler was wrecking a TA 650 so got in touch and, happily, the airbox was still available and in good condition.

However, when it arrived I found that it was starting to distort like my original airbox. Nowhere near as bad but definitely starting to do the same thing.

So, perhaps this IS a common problem?

I have fitted the new 'box, run a smear of grease around the mating surfaces of the top and bottom halves and then run a waterproof tape around the join. Simple and cheap steps to hopefully ensure the airbox is fully sealed. Seeing all the dust on the clean side of the filter disturbed me.
 
1 - 3 of 3 Posts
Top