Honda XRV Forum banner

1 - 4 of 4 Posts

·
Ridden for years
Joined
·
2,805 Posts
Discussion Starter #1
Just broken my rear indicator shaft just covering the bike :mad::mad:
Only had the bike two weeks:mad:
Can someone shed some light. There is absolutely no give in the rear indicators, I can't believe that's right; or standard.
It's a 56 model and has had givi side racks fitted. The indicators are mounted beneath the rack. Is this standard? I'm guessing the previous owner may have re-situated the lights. Does anyone know of a suitable replacement set which offer some flexability in the shaft like the old Dommies had.
Cheers

John
 

·
Registered
Joined
·
12,768 Posts
Most times the indicators are moved to under the rack when pannier racks are fitted.
The Dommie style indicators should fit so you will just need to find a set.
 

·
Registered
Joined
·
585 Posts
There are plenty of aftermarket ones available if you want to go that route. I had a problem with one of mine on the Vigor, the bodies are as fragile as eggshells and I sussed that it was damaged on assembley. I superglued it and sprayed it afterwards and it's not too bad. Regards the shaft on yours, could you drill down each side a bit and insert a pin then superglue the lot back together. You have nothing to lose, it's busted. Hang on silly me! the wires run down the middle of it but you could still try a repair of this sort. Give it a go as I say you have nothing to lose. Good luck.
 

·
Ridden for years
Joined
·
2,805 Posts
Discussion Starter #4
Thanks guys, I guessed they'd been relocated, I did the same thing on an old bike when I fitted panniers rails. Good ol' insulation is doing the job for now, same colour and does the job. Still might kee an eye out for some Dommie ones.:thumbup:

Actually, egg shells are stronger, you can stand on those:D
 
1 - 4 of 4 Posts
Top