Honda XRV Forum banner

21 - 29 of 29 Posts

·
Registered
Joined
·
326 Posts
Discussion Starter #23
We’ll haven’t had much chance to work on my bike lately, just went out to have a look and plan some tasks and noticed that I got oil leaking from the strainer?

I refitted the oil strainer with new o-ring and did it up as tight as I could but didn’t not have my torque wrench at the time, so just wondering if anyone had managed to torque up strainer without removing oil pipe??

Also I noticed that I can see a bit of light between flange of strainer and frame.
Has anyone ever noticed this??
 

·
Registered
Joined
·
326 Posts
Discussion Starter #24
I took oil strainer out a few weeks ago, cleaned up any lumps in the powder coat and refitted strainer and torqued it up correctly.
Just been out and checked and I’m leaking oil again.
The only thing o can think is, that perhaps the powder coat is really thick on the bottom of frame where the flange of the oil strainer is sitting against, and when this bottoms out, it’s not compressing o-ring enough, or not at all.
I thinking about using a slightly thicker o-ring?
What’s everyone’s thoughts on this??
 

·
Registered
Joined
·
2,209 Posts
Only just noticed your question from 3 months ago. You shouldn't need a thicker O ring, there must be something wrong. I've taken mine out a couple of times and re used the original o ring.
I Just whipped the bash plate off mine to take a photo its a bit of a mess but no leaks let me know if you see something you want more info on

IMG_9265.JPG
 

·
Registered
Joined
·
326 Posts
Discussion Starter #27
Thanks Fred, I can’t see anything different, I did have my frame powder coated, there was a little lump of powder coat but I’ve removed that now.
I havnt even started the bike, it’s just leaking through anyway, 🤬🤬
 

·
Registered
Joined
·
2,209 Posts
I thought there was a recess that the oil strainer sits in on the bottom of the frame just a small step maybe the paint has smoothed that out. might be wrong its been a while, Google is shite i just searched for photos of the NX650 frame strainer and there was a picture of my Africa Twin in amongst all the other useless photos not related to the search LOL
 

·
Registered
Joined
·
326 Posts
Discussion Starter #29
Haha, yeah there is a recess that the o-ring sits in, ive checked that it’s clean, fitted another new o-ring and torqued it up again, and see if that sorts it out
 
21 - 29 of 29 Posts
Top