Honda XRV Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
I've put some LED indicators on my 650L to replace the huge ugly standard things.....however.......
With all 4 LED indicators wired up, all 4 flash......like hazzard lights:(
If I then put standard indicators on the front, with a new LED type relay, all is fine:thumbup:

So I'm confused....I need a relay that can handle all 4 LED indicators....

Any advice

cheers
 

·
Premium Member
Joined
·
6,922 Posts
I've put some LED indicators on my 650L to replace the huge ugly standard things.....however.......
With all 4 LED indicators wired up, all 4 flash......like hazzard lights:(
If I then put standard indicators on the front, with a new LED type relay, all is fine:thumbup:

So I'm confused....I need a relay that can handle all 4 LED indicators....

Any advice

cheers
If you put your LED indicators back on, with the LED relay, and pull the dash indicator repeater lamp then your indicators will work as they should.

Your problem is caused by the way Honda decided to wire the indicator dash repeater lamp. Kingdirt had the same problem on his Africa Twin and the solution is the same, so I won't repeat what I have already posted.

Any other questions, just ask.



100% free webcam site! | Awesome chicks and it is absolutely free! | Watch free live sex cam - easy as 1-2-3
 

·
Registered
Joined
·
35 Posts
go to your local Honda dealership, and ask for a 3 pin LED relay..the XR400 (suspect its the same as the XR250) relay for the indicators is to the right, just infront of the tank, unplug it, plug the new one in..all good...if not, do wot i did, and wire in some resistors (mine came prewired from MCS), plug red to power (green for front right, blue for front left, pink i think is rear left and orange for rear right, green is earth on all 4.) be careful tho, the earth has a dual pluggy thing coming off the one wire. dont crimp it.
 
1 - 4 of 4 Posts
Top