Honda XRV Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
hi all
i returned from a ride and noticed coolant coming out of small hole under water pump - i ordered some replacement seals but it has made no difference
is this fixable or has the shaft worn so therefore a good seal impossible
its a 35,000 miler 2001 model 650 TA
i have priced a replacement pump with David Silver at about £300 - not an option
is there somewhere i can send pump off to be repaired etc
thanks
tony
 

·
Registered
Joined
·
11 Posts
I have exactly the same problem. Was so annoyed when the seals I bought did not cure the problem!

As far as I can tell, we need to physically dismantle the pumps. Here are a couple of You-Tube videos showing the idea:

https://youtu.be/XGAL6P9vLb0

https://youtu.be/W5H1AokofNM

First you need to remove what they call the impeller. You need a lot of heat for that, I think they are using Oxy-Acetylene. I tried it with my propane blowtorch but, as the guy says in the video, I could not get it hot enough. Hopefully someone at my work can help. If using a vice you need to grip the centre of the impeller, not the blades.

There is then a seal inside the pump body. These seals seem to be available on eBay (UK) from seller happybikes000.
 

·
Registered
Joined
·
11 Posts
Just a quick update to this thread.

When my first water pump started leaking, I was able to get a replacement from a local breakers. When THAT started leaking after just 200 miles, I had to bite the bullet and order a new one. I shopped around a bit and got one from the USA for about 185 GBP.

waterpump2.JPG

The guys in the vehicle maintenance dept at my work were completely unable to get either old impeller off. Let's hope the new pump lasts!
 
1 - 3 of 3 Posts
Top