Honda XRV Forum banner

1 - 5 of 5 Posts
M

·
Guest
Joined
·
0 Posts
Discussion Starter #1
Can anyone help with a source for a new or second hand original fitment digital speedo and trip for my 1995 XR250 Baja, the one fitted only works occasionally, though when it does everything on it works fine. I've checked all the usual connections etc and even resoldered the wires to the circuit board in the speedo in case of a dry joint, but it's still the same. There is power getting to the circuit board even when it decides not to work, so I think it's a component breaking down or a dry joint. No amount manipulating cables will bring it on or off once the ignition is on. The only way it does or doesn't work is when you switch on. :confused:
I've seen some XR250's for sale on E-bay that also seem to have digital speedo's even though they are not Baja's. Does anyone know if the speedo's are the same on both bikes?

Mark
 
M

·
Guest
Joined
·
0 Posts
Discussion Starter #3
Thanks for the response. Fortunately I also own an Africa Twin and although both units do look very similar, the one on the Africa Twin is only a clock and trip meter, where as the Baja's has a speedo built in to the electronics too.:( I'm off to the BMF this weekend. If I'm really lucky I may stumble across one walking round the auto jumble!
 

·
Registered
Joined
·
1,309 Posts
M

·
Guest
Joined
·
0 Posts
Discussion Starter #5
Thanks very much for the links, :D I've just spent a couple of hours reading all the information and there are definately problems that others have experienced which are like mine. It's given me the urge to have another look at it and take some voltage readings etc. I'll let you know how I get on.
 
1 - 5 of 5 Posts
Top